Application Down
Incident Report for Breathe
Resolved
Breathe is now back up. We apologise for the short interruption of service.
Posted 7 months ago. Feb 04, 2019 - 18:35 UTC
Investigating
Breathe is currently unavailable. Engineers are investigating.
Posted 7 months ago. Feb 04, 2019 - 18:28 UTC
This incident affected: breatheHR Application.