Performance issues for RTA and mobile app

Incident Report for Breathe

Monitoring

Performance for the Rota, Time & Attendance add-on and mobile app have returned to normal. We'll continue to monitor.
Posted Jun 05, 2025 - 09:23 UTC

Investigating

We're aware some customers are experiencing slow loading times when using the mobile app and the Rota, Time & Attendance add-on.

Our team is actively investigating this issue and working to restore normal performance as quickly as possible.

Thank you for your patience.

Team Breathe
Posted Jun 05, 2025 - 08:25 UTC
This incident affects: ROTA Application and People Portal (Mobile App).